Atari Music Network | Chiptune & MIDI Music

Mega STE questions

Re: Mega STE questions

Postby mal7921 » Thu Feb 28, 2013 12:46 pm

Ah, the good old MIDEX+, that device is great :-)

Glad the ROM swap went OK, in the picture you can see the SCSI interface board for the ST series, always worth re-seating if your hard drive falls off the planet for no explainable reason. I don't think its screwed down, but if it is it won't be more than 2 screws.
The collection:

Atari 260ST, 520ST, 520ST+, 520STfm, STacy, Mega ST2
Atari STe, Mega STE, ST Book
Atari TT030, with 2GB Hard drive
Atari Falcon, 14MB, 40GB IDE drive
Atari Megafile 44

The website and the Atari bit
User avatar
mal7921
 
Posts: 410
Joined: Tue Apr 06, 2010 11:44 am
Location: Huddersfield, U.K.

Re: Mega STE questions

Postby somaboy » Thu Feb 28, 2013 4:01 pm

The only thing that bothers me about the Midex is that it's a loose fit in the cartridge port. I've already had cubase freeze on me a couple of times because I accidentally pushed the Midex slightly out of position while inserting or removing midi cables. Guess I'll have to fix it to my desk with double sided tape or velcro, unless you have a better suggestion.

The position of the keyboard cable is also a bit awkward with the Midex in place, but I can cope with that.

Another question: does Cubase 2.0 run in 16mHz mode on a Mega STe? And does that improve the performance (e.g.. faster screen redraws, scrolling etc.)?
somaboy
 
Posts: 25
Joined: Sun Jan 02, 2011 12:58 am

Re: Mega STE questions

Postby mal7921 » Thu Feb 28, 2013 5:24 pm

I had that as well with the keyboard cable, unfortunately there's not much you can do about it due to the position on the case. I think I put the cable as flat as I could against the case and taped it there with duct tape, it was certainly something like that as the cable didn't move and it was a pain to take back off when the machine went into storage during my divorce.

Unfortunately my Midex went missing and has never been found, so I can't try anything similar, but taping the cable to the lower edge of the case would help keep it out of the way.
The collection:

Atari 260ST, 520ST, 520ST+, 520STfm, STacy, Mega ST2
Atari STe, Mega STE, ST Book
Atari TT030, with 2GB Hard drive
Atari Falcon, 14MB, 40GB IDE drive
Atari Megafile 44

The website and the Atari bit
User avatar
mal7921
 
Posts: 410
Joined: Tue Apr 06, 2010 11:44 am
Location: Huddersfield, U.K.

Re: Mega STE questions

Postby NCGM » Thu Feb 28, 2013 6:07 pm

somaboy wrote:I already bought the 2.06 UK roms on Ebay last week ;)
They should arrive anytime soom. Hope I'm not gonna have to do any soldering to install them.


I had a couple of sets of TOS 2.06 UK EPROMs laying around and installed them in my MEGA STE. Although these worked fine in my standard 4160STE machines, they became scalding hot in the MEGA STE. I then had someone from Atari-Forum.com to burn a copy of their MEGA STE EPROMs and send me a set, and they work perfectly and stay cold. It was either Dal or dml that did them, so I would need to check who.
NCGM
 
Posts: 180
Joined: Wed Apr 07, 2010 12:02 pm
Location: Bradford, U.K.

Previous

Return to Atari ST, STe, STF, STFM

Who is online

Users browsing this forum: No registered users and 1 guest

cron